Parece que Apple se ha dado por vencida con las posibilidad impedir que los usuarios puedan hacer jailbreak y desbloqueo de los iPod touch y iPhone. Sin embargo, ahora se defiende por otro lado: iTunes.

Específicamente es la nueva versión, iTunes 8, la que empieza a reconocer aquellos dispositivos que no cuentan con un firmware original, impidiendoles realizar una sincronización exitosa y obligando -por el momento- a los usuarios de iPod touch a restaurar sus gadgets.

Pero el iPhoneDevTeam nos explica esto:

El jailbreak/unlock no puede ser impedido vía software, tiene que haber cambios de hardware para que Apple pueda obstruir de nuevo éste método (refiriéndose a Pwnage Tool). Lo mejor de todo es que podemos ofrecerles parches para saltar esta verificiación de iTunes; actualmente tenemos lista la versión para Mac y el iPod touch, pero para la próxima semana tendremos todos los parches necesarios.

Supongo que con eso se refieren a que tendrán lista una versión actualizada de Pwnage Tool que sea compatible con iTunes 8 y el firmware 2.1 para el iPhone y iPod touch en versiones para Mac y Windows (WinPwn). Además dejan una pista:

¿Algún experto en Unix que nos explique un poco?

Actualización: gracias a los lectores, me he dado cuenta de un error de lectura. Más bien bloquea la restauración del dispositivo cuando se pretende usar un firmware modificado. Si tu iPod touch o iPhone tiene jailbreak o desbloqueo, no tendrás problema en sincronizar.

Enlace: iPhone Dev Blog